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Before you start preparing your InDesign template for your Lytho environment, make sure that you have
the Lytho Template Builder installed on your device. In order to install the Lytho Template Builder make
sure that: 

You have the latest version of InDesign CC installed. 
You have access and permission to install plugins from the Adobe Exchange.

Preconditions to InDesign Documents in Lytho 
Use paragraph styles 

All separate fields of text that will be editable for the user need to have paragraph styles
assigned to them. To manage your paragraph styles, go to [Window > Styles > Paragraph
Styles]. Character styles can be added on top of this, (i.e.) when one word in a paragraph needs
to be formatted in a different style.

It is best practice to assign every different styled paragraph with its own unique paragraph style. Some
advantages of paragraph styles:

You can reuse a paragraph style for different text in the same document.
Editing a paragraph style will affect all the styled paragraphs, so you don’t have to change the
styling in every affected area.
Paragraph styles can be copied to new/existing documents to ensure consistency throughout a
wide variety of templates.
Last but not least: Defined paragraph styles are uploaded to Lytho so users can choose their
favorite predefined style in a text field (only if it’s defined as a rich-text field).

Download the template builder plugin from the Adobe Marketplace. 
(https://exchange.adobe.com/creativecloud.details.104361.lytho-template-builder.html)
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Checking for style overrides

To ensure the output from Lytho will have the correct paragraph styles, we highly recommend
checking for style overrides before uploading your design to Lytho. In the Paragraph Styles
window, look for the Style Override Highlighter button “[a+]”. Selecting this button will
highlight all the paragraphs with style overrides. Walk through all the highlighted paragraphs
and redefine your style or clear the overrides.

Document naming 

Create a logical file name for the document. Document names are included in Lytho global
searches so you can easily find the document later in the DAM templates. Therefore, the name
should be intuitive and take into account all other templates that need to be uploaded to
Lytho.  

Structuring layers 

Certain elements like text or shapes can be shown on top of one of your images in the
template. In that case, make sure that elements are in separate layers and in the correct order,
meaning that images with text atop should be in a layer beneath the layer containing the text.

No embedded images 

All images in the InDesign file must be linked, not embedded. Open the Links window [Window
> Links] and look for the embedded icon. Read this article to learn everything about linking
images in InDesign.

Checking for errors 

Before uploading the file to Lytho, check for errors in your InDesign document by going to
[Window > Output > Preflight]. The Preflight panel will show any errors. Fix missing fonts and
missing links to images to prevent unwanted output.
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Check text space in the document 

Double-check that text frames contain enough space for paragraphs that might be longer when
the copy is edited in the template and make sure that text frames do not overlap each other.

Parent pages 

It is best practice to place all of the editable elements on the document pages, not on parent
pages. If the parent page contains elements you want to use in the template, move them to the
relevant document pages before uploading the template to Lytho.

Using the Lytho InDesign Plugin
To prepare a template for your Lytho environment, open the Lytho Plugin via [Window > Extensions >
Lytho | Templates].

The template builder will now appear with the login menu. You will fill in the following information:

Tenant-select.organization: Use the same name as the one used in the Lytho URL
https://[organisation].Lytho.io
https://[organisation].us-1.lytho.us

Region:
EU (lytho.io) for Europe
US (us-1.lytho.us) for United States

Folder to store downloaded files: Choose a local folder where the template builder can gather
files to send to the server.

Click Continue when you’ve filled in all information to log in. The following message will appear in the
plugin:
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The Lytho template builder will open a new browser tab and bring you to the Lytho login page. After
logging in through the browser (or if you are already logged in), you’ll be notified of successful
authorization and that the Template Builder is ready to use.
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Getting Started with the Template Builder
Once logged in, the Template Builder will open the list with your uploaded InDesign files which are ready to
create templates from in Lytho.

Here you have the following options:

Create a new template - This will bring you to a new page with two new options:

Select from your pc -  This option will open a new explorer/finder window where you can
select the InDesign file you’d like to prepare and upload as a Lytho template.
Select active file -  This option only applies when your InDesign file is already opened.

The Template name is a copy of the InDesign file name and cannot be edited in this phase (you can edit it
later). The Location in the template overview (optional) is the location in the Template Builder folder-
structure. With this, you can only select existing folders. If you want to add a new folder to this structure,
please read the next paragraph of this document.

Create Folder - This function allows you to create a folder structure in your Template Builder extension. It
will be easier to find your templates if they’re grouped in folders per (sub-)brand, division, type, or any
structure you prefer.

Settings - The settings button brings you back to the menu where you can logout or change the folder on
your local computer to store the files before uploading them to the server.

Opening Your InDesign Document and Creating Fields
There are a few ways to get started with an InDesign document: 

1. Open an existing InDesign document. 
2. Create a new InDesign document. 
3. Double click one of the pre-uploaded templates in the Template Builder or use the actions

menu and select Download.

With the InDesign file created/selected, it is time to designate which fields will be editable in Lytho. First,
you will create new fields, then you will link the InDesign elements to these fields. From the Templates
window, click ok the actions menu and select Edit fields or click on the arrow button. The Template fields
window will open.

There are two ways to create fields in the Template Builder:

Add fields - Create new fields one by one.
Import fields - You can use an Excel file to import multiple fields at once. This comes in handy
when using the same fields in multiple templates.  

To import, create an Excel file with all the field names spread over the columns of the first row e.g.:
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Uploading this file will result in adding five new fields to the template you’re creating in the Template
Builder: 

1. Title 
2. Header 
3. Image 1 
4. Image 2 
5. Phone number

Linking Your Fields to the InDesign Elements
Now that you have identified your editable fields, associated elements need to be linked to these fields so
that later Lytho can distinguish static versus editable elements

There are four ways to link InDesign elements to Template Builder fields:

Partial text

Be aware that the names that you use for the fields are also the names that the users in Lytho
will see. Therefore, make sure to use intuitive names. Moreover, it’s possible to select multiple
InDesign documents as input for a template. For example, you have a campaign with posters
and flyers, which have the same image, title, and tagline. If you make sure that these field
names are exactly the same in both documents, users only have to fill in the fields once for
creating both outputs.
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If you want the user in Lytho to change only a part of a paragraph, only select that specific part of the text
with the Type Tool. With the copy highlighted, select the respective field in the Template fields window and
click the link icon. In the below example, only the username part of the email address will be editable; the
domain name, because it was not part of the selected copy when linked to the template field, will not be
editable.

Text frames

To give a user the freedom to adjust the entire input of a text frame, you don’t have to select the Type Tool
and highlight all the placeholder text in the frame. This can be done more easily by selecting the text frame
with the Selection Tool and then clicking the link icon in the Template Builder.

When a text frame is linked, in contrast to partial text, all the text inside the frame can be overwritten by a
Lytho user.
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When a text frame is linked, there are two options for fitting the content to the text frame — either fit the
content to the text frame or keep the text values and cut off all overwrites. You can make this assignment
by going to Object > Text Frame Options (be sure your text frame is selected).

Image frames

Select the image frame and select your respective field then link it with the link icon in the Template
Builder. The image frame will be filled with the image selected by the user in Lytho. 

Filling a frame with an image can be done in three different ways:

1. Fit content to frame
2. Fit content proportionally
3. Fill frame proportionally.

You can access these settings in two ways (either way, be sure the image frame is selected) — select the
Frame fitting options in the Template field window’s Options kebab menu or go to Object > Fitting >
Frame fitting options
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Select Auto Fit, select the desired way of fitting the image and set all crop values to 0 mm.

Do not to link an empty frame. Make sure to insert a placeholder image in the frame so that the preview
provides a clear picture to you and other Lytho users of what the publication is supposed to look like. 

In case multiple images are being used — or certain elements are being shown on top of the image —
make sure that all editable images are in separate layers below the layer containing the other elements
that should display on top.

Color Frames 

Select the color frame and select your respective field then link it with the link icon in the Template Builder.
If you have multiple color frames, you will need to link all of them to the same Lytho field to ensure that all
of these frames are available to select when a user changes the theme color in Lytho.
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Uploading Your InDesign Document to Lytho
When you’re finished linking the fields of the InDesign document, the final step is to upload the document
to Lytho. What’s important here is to always save your InDesign document locally on your pc before
uploading. Use File > Save or [ctrl + s] for Windows or [cmd + s] for Mac.

To upload your saved file, navigate to the Templates window in the Template Builder extension, click on
the actions menu and select Sync to Lytho. 

In case of updating an existing template, the Template Builder will now ask you if you are sure you want to
overwrite the existing file on the server. After approval, a spinner will show the uploading progress. When
reaching 100%, the file has been successfully uploaded. Now all that is left is to configure the template in
Lytho.
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Have a friend who could benefit from Lytho? Refer them and get a $200 gift card!
(https://www.lytho.com/share-the-lytho-love/)
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